Imunify360导致php故障

自动更新对于保持系统的更新往往是有用的,也是必要的。为此,服务器上会自动安装和更新软件包。Imunify360的安全包也是如此。 Plesk 服务器。

从19.11开始,有一些包更新到另一个版本。这显然会导致服务器上的php进程在短时间内终止。

如何判断自己是否受到影响?

这个问题是通过错误日志中的错误信息发现的,或者在较长的脚本运行时间中,当调用被终止时,出现503错误信息,或者internel服务器错误。

最快的方法是使用webmail,Plesk服务器使用Php7.3版本。登录后直接会出现服务器内部错误,你可以通过多次调用跳过。

显示在Error_log中

当你登录webmail时,数据是从imap邮箱中读取的,这需要更长的时间。在正常情况下 网站 调用的是毫秒级的php调用,所以问题不是很明显。

但在使用 WordPress 例如,如果你从其他服务器导入设计模板或上传图片,可能会导致崩溃。

如何解决这个问题?

遗憾的是,无法通过恢复旧版本等方式解决问题。即使卸载imunify360后,php错误也没有修复。

但解决方法比较简单。

imunify360-logo

步骤1:卸载Imunify360。

使用以下命令可以下载Imunify360部署脚本并卸载imunify360。

wget https://repo.imunify360.cloudlinux.com/defence360/i360deploy.sh

bash i360deploy.sh -uninstall

这个过程需要一段时间,因为所有的域名都在这里处理。对于100个域名约15分钟。

步骤2:安装Imunify360

如果imunify360被完全禁用,可以通过以下命令轻松重新安装。

bash 360deploy.sh

之后,必须在Plesk菜单中再次激活许可证密钥。然后,php错误信息又会消失。

请将捐款分成
分享到facebook
分享到twitter
分享到linkedin
分享到pinterest
分享到whatsapp
分享到telegram
最新文章

我们Youtube频道的推荐视频